Excel || Som van de top 3


http://www.ExcelXL.nl
|| In deze video laat ik je zien hoe je met een combinatie van de functie SOM en GROOTSTE uit 10 scores, de top 3 bij elkaar optelt. Ook krijg je de formule van de totale score verminderd met de laagste én de hoogste score te zien.

Hallo en welkom bij ExcelXL.nl.

Mijn naam is Jan Bolhuis en in deze video ga ik je laten zien hoe je van een reeks getallen de top 3 bij elkaar kunt optellen.

Dit kun je het snelst realiseren door de functie SOM met de functie GROOTSTE te combineren.

Om dit stap voor stap uit te leggen ga ik eerst laten zien wat het grootste getal is. En dat doe je door middel van de functie GROOTSTE.

Ik ga naar cel L2 en begin net als altijd met het is gelijk aan teken gevolgd door de functie GROOTSTE.

Dan zie je dat het eerste argument van deze functie een matrix is en in dit geval betekent dat een bereik.

Ik selecteer het bereik gevolgd door een puntkomma en dan zie je dat het tweede argument een k is. En de k staat voor welk grootste getal je wilt zien.

Wil je het allergrootste getal zien dan is de k een 1. Wil je de op twee na grootste getal zien dan is k een 3. Ik voer hier een 1 in omdat ik het grootste getal wil zien. Ik sluit af met een haakje en bevestig met Enter. Even doortrekken met de vulgreep en alle cellen zijn gevuld me het grootste getal.

Om te laten zien dat Excel daadwerkelijk wanneer ik de k — dus de 1 — verander in een 3 daadwerkelijk ook de op twee na hoogste getal laat zien verander ik de één nu even in een drie. Bevestigen met Enter. Doortrekken met de vulgreep en van alle rijen wordt de op twee na hoogste getal getoond. Ik zet het weer even terug op het grootste getal.

En ga nu laten zien hoe je de som van de drie grootste getallen kunt berekenen.

Ik begin weer met het = gelijk aan teken gevolgd door de functie grootste, haakje openen. Ik geef opnieuw het bereik aan gevolgd door een puntkomma.

Om nu de grootste 3 getallen aan te geven, moet ik beginnen met een accolade gevolgd door de cijfers 1 backslash 2 backslash 3 en ook afsluiten met een accolade en nog een haakje.

En vervolgens bevestigen met Enter.

Nu zie je dat Excel opnieuw het grootste getal laat zien. Echter wanneer we de formule gaan evalueren door in de cel te gaan staan en de k te controleren met behulp van de F9 toets dan zie je dat daadwerkelijk de drie grootste waarden worden weergegeven.

Ik selecteer de formule en met behulp van de F9 toets zie je dat Excel de drie grootste waarden weergeeft. 98, 96 en 92

Met de Escape toets ga ik weer terug naar de formule en

Nu is het nog een kwestie van de functie SOM toe voegen door opnieuw in de formule te gaan staan en achter het is gelijk aan teken de functie som. Haakje openen, aan het einde van de formule nog even een haakje sluiten om de formule af te sluiten en bevestigen met Enter.

En op deze manier telt Excel de drie grootste getallen bij elkaar op.

Een andere veel toegepast systeem in competities is dat alle punten bij elkaar worden opgeteld en dat de laagste én de hoogste score er weer vanaf worden getrokken.

Ook dat laat ik nog even zien door in cel N2 te gaan staan en de volgende formule te plaatsen.

=SOM(B2:K2)-MIN(B2:K2)-MAX(B2:K2)

= som, haakje openen, het bereik, haakje sluiten, verminderd met het kleinste getal en dat doen we met de functie min. Opnieuw geven we het bereik aan waarin het kleinste getal moet worden gezocht, haakje sluiten. En verminderd met het grootste getal en dat doen we met behulp van de functie max, haakje openen, opnieuw het bereik aangeven waarin het maximum getal moet worden gezocht, haakje sluiten en bevestigen met enter

Vervolgens nog even dubbelklikken op de vulgreep en alle cellen zijn weer gevuld.

Ik bedank je weer voor het kijken en zie je graag weer terug op ExcelXL.nl waar ik nog veel meer tips en trucs met je wil delen.

13 thoughts on “Excel || Som van de top 3”

  1. ExcelIsFun says:

    Thanks for the video!

    1. ExcelXL.nl says:

      You’re welcome.

  2. ExcelIsFun says:

    Thanks for the video!

    1. ExcelXL.nl says:

      You’re welcome.

  3. Loet van kimmenade says:

    Hoe kan ik nu de 3 grootste getallen een voorwaardelijke opmaak geven? B v
    cijfers rood maken!

    1. ExcelXL.nl says:

      +Loet van kimmenade Beste Loet, Bekijk deze video eens? https://youtu.be/-BUysAf20bw

  4. Loet van kimmenade says:

    Hoe kan ik nu de 3 grootste getallen een voorwaardelijke opmaak geven? B v cijfers rood maken!

  5. Loet van kimmenade says:

    Hoe kan ik nu de 3 grootste getallen een voorwaardelijke opmaak geven? B v cijfers rood maken!

    1. ExcelXL.nl says:

      +Loet van kimmenade Beste Loet, Bekijk deze video eens? https://youtu.be/-BUysAf20bw

      1. Loet van Kimmenade says:

        Beste Jan,
        In de reeks van 20 getallen kunnen bij de beste getallen meer dan 3 getallen voorkomen. en toch wil ik maar 3 getallen opmaken omdat die 3 getallen ook als som worden gebruikt.
        B.v. 10, 9, 9, 8, 8, 7, 6, 5, 6, 5
        Alleen de 3 beste getallen mogen opgemaakt worden; dus 10, 9 en 9

        B.v.d. en groet,

        Loet

  6. Erik Steen says:

    Dank voor de uitleg, heeft me geholpen bij het opzetten van een scorelijst..
    Onze competitie is 16 wedstrijden en de beste 12 worden meegenomen in de ranglijst.
    Kan er ook een totaal komen indien er geen 12x is meegedaan? er staat nu #getal!

    1. Jan Bolhuis says:

      Beste Erik,

      Je kunt gebruik maken van de ALS.FOUT functie. In dit voorbeeld ga ik ervan uit dat de scores in het bereik B2:Q2 staan. De formule komt er dan als volgt uit te zien:

      =ALS.FOUT(SOM(GROOTSTE(B2:Q2;{1\2\3\4\5\6\7\8\9\10\11\12}));SOM(B2:Q2))

      Wanneer er nu een fout voorkomt in het stukje SOM(GROOTSTE(B2:Q2;{1\2\3\4\5\6\7\8\9\10\11\12})) – wat dus het geval is in geval van minder dan 12 scores – dan zal SOM(B2:Q2) worden uitgevoerd.

      Wanneer je goed op de screentip let, zul je zien dat SOM(GROOTSTE(B2:Q2;{1\2\3\4\5\6\7\8\9\10\11\12})) het eerste argument is van de ALS.FOUT functie en SOM(B2:Q2) het tweede argument.

      Hieronder de formule in het Engels.

      =IFERROR(SUM(LARGE(B2:Q2;{1\2\3\4\5\6\7\8\9\10\11\12}));SUM(B2:Q2))

      Succes.

      Met een ExcelLerende groet,
      Jan

  7. Erik says:

    Top, functie toegevoegd en lijst is nu zoals gewenst.
    Dank voor je snelle en waardevolle reactie.

    Groet
    Erik

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *